import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+)\\W+\\w+\\W+(\\w+)";
final String string = "health status index pri rep docs.count docs.deleted store.size pri.store.size \n"
+ "yellow open first_index 5 1 222173 0 43.8gb 43.8gb \n"
+ "green open second_index 5 1 27131 7 36.6gb 36.6gb \n"
+ "red open third_index 5 1 4047 0 22.4mb 22.4mb \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}