using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""ProductGroup"": ""[^-]*?""";
string input = @"""ProductGroup"": ""Wels-RC""
""ProductGroup"": ""Wels-OC""
""ProductGroup"": ""wohphen""
""ProductGroup"": ""RBE-RC""
""ProductGroup"": ""WXE-TN""
""ProductGroup"": ""wohphen""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}