// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"ProductGroup": "[^-]*?""#).unwrap();
let string = "\"ProductGroup\": \"Wels-RC\"
\"ProductGroup\": \"Wels-OC\"
\"ProductGroup\": \"wohphen\"
\"ProductGroup\": \"RBE-RC\"
\"ProductGroup\": \"WXE-TN\"
\"ProductGroup\": \"wohphen\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}