re = /"ProductGroup": "[^-]*?"/m
str = '"ProductGroup": "Wels-RC"
"ProductGroup": "Wels-OC"
"ProductGroup": "wohphen"
"ProductGroup": "RBE-RC"
"ProductGroup": "WXE-TN"
"ProductGroup": "wohphen"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end