$re = '/"ProductGroup": "[^-]*?"/m';
$str = '"ProductGroup": "Wels-RC"
"ProductGroup": "Wels-OC"
"ProductGroup": "wohphen"
"ProductGroup": "RBE-RC"
"ProductGroup": "WXE-TN"
"ProductGroup": "wohphen"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);