using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{.*}";
string input = @"This is a text that says nothing
Another string of that useful text
Below something more interesting
/BEGIN/
{
""something"" : ""interesting"",
""thatcanbe"" : ""parsedproperly""
}
/END/";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}