$re = '/{.*}/s';
$str = 'This is a text that says nothing
Another string of that useful text
Below something more interesting
/BEGIN/
{
"something" : "interesting",
"thatcanbe" : "parsedproperly"
}
/END/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);