re = /{.*}/
str = 'This is a text that says nothing
Another string of that useful text
Below something more interesting
/BEGIN/
{
"something" : "interesting",
"thatcanbe" : "parsedproperly"
}
/END/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end