#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?\s[N]{0,1}([-a-zA-Z0-9]+)\s*\w*$"
Local $sString = "2038 W MAIN AVE" & @CRLF & _
"2038QWEW S JEFFERSON AVENUE" & @CRLF & _
"33 NORTH CALIFORNIA STREET" & @CRLF & _
"53371 SOUTH WASHINGTON" & @CRLF & _
"53371 S WASHINGTON AVENUE" & @CRLF & _
"1600 E PENNSYLVANIA AVE" & @CRLF & _
"WEST9 67ST ST" & @CRLF & _
"E171 N 23RD STREET" & @CRLF & _
"G171 N121ST STREET" & @CRLF & _
"G171 N121ST SQUARE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")