import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\s[N]{0,1}([-a-zA-Z0-9]+)\\s*\\w*$";
final String string = "2038 W MAIN AVE\n"
+ "2038QWEW S JEFFERSON AVENUE\n"
+ "33 NORTH CALIFORNIA STREET\n"
+ "53371 SOUTH WASHINGTON\n"
+ "53371 S WASHINGTON AVENUE\n"
+ "1600 E PENNSYLVANIA AVE\n"
+ "WEST9 67ST ST\n"
+ "E171 N 23RD STREET\n"
+ "G171 N121ST STREET\n"
+ "G171 N121ST SQUARE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}