# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?\s[N]{0,1}([-a-zA-Z0-9]+)\s*\w*$"
test_str = ("2038 W MAIN AVE\n"
"2038QWEW S JEFFERSON AVENUE\n"
"33 NORTH CALIFORNIA STREET\n"
"53371 SOUTH WASHINGTON\n"
"53371 S WASHINGTON AVENUE\n"
"1600 E PENNSYLVANIA AVE\n"
"WEST9 67ST ST\n"
"E171 N 23RD STREET\n"
"G171 N121ST STREET\n"
"G171 N121ST SQUARE")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.