package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?\s[N]{0,1}([-a-zA-Z0-9]+)\s*\w*$`)
var str = `2038 W MAIN AVE
2038QWEW S JEFFERSON AVENUE
33 NORTH CALIFORNIA STREET
53371 SOUTH WASHINGTON
53371 S WASHINGTON AVENUE
1600 E PENNSYLVANIA AVE
WEST9 67ST ST
E171 N 23RD STREET
G171 N121ST STREET
G171 N121ST SQUARE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}