#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=//)(?:www\.)?(.*)(?=.com)"
Local $sString = "domain_name("http://github.com/carbonfive/raygun") == "github" " & @CRLF & _
"domain_name("http://www.zombie-bites.com") == "zombie-bites"" & @CRLF & _
"domain_name("https://www.cnet.com") == "cnet"" & @CRLF & _
"domain_name("https://docs.python.com") == "cnet""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")