using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=//)(?:www\.)?(.*)(?=.com)";
string input = @"domain_name(""http://github.com/carbonfive/raygun"") == ""github""
domain_name(""http://www.zombie-bites.com"") == ""zombie-bites""
domain_name(""https://www.cnet.com"") == ""cnet""
domain_name(""https://docs.python.com"") == ""cnet""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}