import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=//)(?:www\\.)?(.*)(?=.com)";
final String string = "domain_name(\"http://github.com/carbonfive/raygun\") == \"github\" \n"
+ "domain_name(\"http://www.zombie-bites.com\") == \"zombie-bites\"\n"
+ "domain_name(\"https://www.cnet.com\") == \"cnet\"\n"
+ "domain_name(\"https://docs.python.com\") == \"cnet\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}