import re
regex = re.compile(r"(?<=//)(?:www\.)?(.*)(?=.com)")
test_str = ("domain_name(\"http://github.com/carbonfive/raygun\") == \"github\" \n"
"domain_name(\"http://www.zombie-bites.com\") == \"zombie-bites\"\n"
"domain_name(\"https://www.cnet.com\") == \"cnet\"\n"
"domain_name(\"https://docs.python.com\") == \"cnet\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")