using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(la)(la)*(f.*)";
string substitution = @"$1";
string input = @"lalalalalalaffffff";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}