import Foundation
let pattern = #"(la)(la)*(f.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"lalalalalalaffffff"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)