import re
regex = re.compile(r"(la)(la)*(f.*)")
test_str = "lalalalalalaffffff"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)