#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*a.*)(?=.*b.*)(?=.*c.*)"
Local $sString = "abc" & @CRLF & _
"acb" & @CRLF & _
"bac" & @CRLF & _
"bca" & @CRLF & _
"cab" & @CRLF & _
"cba" & @CRLF & _
"aaa" & @CRLF & _
"bbb" & @CRLF & _
"ccc" & @CRLF & _
"ab" & @CRLF & _
"ba" & @CRLF & _
"cba" & @CRLF & _
"abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")