$re = '/(?=.*a.*)(?=.*b.*)(?=.*c.*)/m';
$str = 'abc
acb
bac
bca
cab
cba
aaa
bbb
ccc
ab
ba
cba
abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);