using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*a.*)(?=.*b.*)(?=.*c.*)";
string input = @"abc
acb
bac
bca
cab
cba
aaa
bbb
ccc
ab
ba
cba
abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}