re = /(?=.*a.*)(?=.*b.*)(?=.*c.*)/m
str = 'abc
acb
bac
bca
cab
cba
aaa
bbb
ccc
ab
ba
cba
abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end