re = /(.*)/m
str = 'foo/bar
FanFicFare rules!'
subst = '[Characters].\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result