#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^|\s)(ул(ица)?|д(ом)?|г(ород)?|пл(ощадь)?|пр(оспект)?|пер(еулок)?)\.?(?=\s|\b)"
Local $sString = "улица Батыршина, д.16 или Батыршина, д.16 или г Москва, ул. Арбат и так далее" & @CRLF & _
"город Москва, ул. Арбат" и так далее" & @CRLF & _
"" & @CRLF & _
"Булгаков"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")