import Foundation
let pattern = #"(^|\s)(ул(ица)?|д(ом)?|г(ород)?|пл(ощадь)?|пр(оспект)?|пер(еулок)?)\.?(?=\s|\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
улица Батыршина, д.16 или Батыршина, д.16 или г Москва, ул. Арбат и так далее
город Москва, ул. Арбат" и так далее
Булгаков
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)