const regex = /(^|\s)(ул(ица)?|д(ом)?|г(ород)?|пл(ощадь)?|пр(оспект)?|пер(еулок)?)\.?(?=\s|\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)(ул(ица)?|д(ом)?|г(ород)?|пл(ощадь)?|пр(оспект)?|пер(еулок)?)\\.?(?=\\s|\\b)', 'g')
const str = `улица Батыршина, д.16 или Батыршина, д.16 или г Москва, ул. Арбат и так далее
город Москва, ул. Арбат" и так далее
Булгаков`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}