$re = '/(^|\s)(ул(ица)?|д(ом)?|г(ород)?|пл(ощадь)?|пр(оспект)?|пер(еулок)?)\.?(?=\s|\b)/';
$str = 'улица Батыршина, д.16 или Батыршина, д.16 или г Москва, ул. Арбат и так далее
город Москва, ул. Арбат" и так далее
Булгаков';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);