#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?P<YEAR>[\d]{4})-(?P<MONTH>([0][1-9])|([1][0-2]))-(?P<DAY>([0][1-9])|([12][0-9])|([3][01]))T(?P<HOUR>([01][0-9])|([2][0-3])):(?P<MINUTES>([0-5][0-9])):(?P<SECONDS>([0-5][0-9])).(?P<MILLIS>[0-9]{3})Z"
Local $sString = "<Id>2016-06-29T17:03:37.000Z</Id>" & @CRLF & _
"<Lap StartTime="2016-06-29T17:03:37.000Z">" & @CRLF & _
"<TotalTimeSeconds>6906</TotalTimeSeconds>" & @CRLF & _
"<DistanceMeters>60870.5</DistanceMeters>" & @CRLF & _
"<Intensity>Active</Intensity>" & @CRLF & _
"<TriggerMethod>Manual</TriggerMethod>" & @CRLF & _
"<Track>" & @CRLF & _
"<Trackpoint>" & @CRLF & _
"<Time>2016-06-29T17:03:37.000Z</Time>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")