import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<YEAR>[\\d]{4})-(?P<MONTH>([0][1-9])|([1][0-2]))-(?P<DAY>([0][1-9])|([12][0-9])|([3][01]))T(?P<HOUR>([01][0-9])|([2][0-3])):(?P<MINUTES>([0-5][0-9])):(?P<SECONDS>([0-5][0-9])).(?P<MILLIS>[0-9]{3})Z";
final String string = "<Id>2016-06-29T17:03:37.000Z</Id>\n"
+ "<Lap StartTime=\"2016-06-29T17:03:37.000Z\">\n"
+ "<TotalTimeSeconds>6906</TotalTimeSeconds>\n"
+ "<DistanceMeters>60870.5</DistanceMeters>\n"
+ "<Intensity>Active</Intensity>\n"
+ "<TriggerMethod>Manual</TriggerMethod>\n"
+ "<Track>\n"
+ "<Trackpoint>\n"
+ "<Time>2016-06-29T17:03:37.000Z</Time>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}