package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[INFO\] \[(\S+):\d+\S+\] Authentication failed with user: '(\S*)'.$`)
var str = `2015-12-02 23:17:35.845 [INFO] [IP.ADD.RE.SS:50364:HTTP2-7] Authentication failed with user: 'username'.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}