import Foundation
let pattern = #"\[INFO\] \[(\S+):\d+\S+\] Authentication failed with user: '(\S*)'.$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2015-12-02 23:17:35.845 [INFO] [IP.ADD.RE.SS:50364:HTTP2-7] Authentication failed with user: 'username'."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}