re = /\[INFO\] \[(\S+):\d+\S+\] Authentication failed with user: '(\S*)'.$/
str = '2015-12-02 23:17:35.845 [INFO] [IP.ADD.RE.SS:50364:HTTP2-7] Authentication failed with user: \'username\'.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end