package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?\B@\w{5}.*`)
var str = `Pattern should match all this lines :
Hi @username how are you?
Hi @username.how are you?
😉@username.
And should not match email like this:
Hi email to something@domain.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}