const regex = /.*?\B@\w{5}.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?\\B@\\w{5}.*', 'gm')
const str = `Pattern should match all this lines :
Hi @username how are you?
Hi @username.how are you?
😉@username.
And should not match email like this:
Hi email to something@domain.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}