package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^N\n]|N(?:[^O\n]|O(?:[^A\n]|$)|$)|$)+`)
var str = `I want to delete anything in a line but stop before the word NOA if that is present in a line. NOA will also follow a colon.
1: NOA Keep this)
2 lkajsflk: DONT KEEP THIS
asdlkjfaskldjf: Dont keep this
asdfjlka: NOA
asdf:NOA(lkjasdlfkjasf)
Version: RE2 for Google Sheets
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}