# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[^N\n]|N(?:[^O\n]|O(?:[^A\n]|$)|$)|$)+"
test_str = ("I want to delete anything in a line but stop before the word NOA if that is present in a line. NOA will also follow a colon.\n\n"
"1: NOA Keep this)\n"
"2 lkajsflk: DONT KEEP THIS\n"
"asdlkjfaskldjf: Dont keep this\n"
"asdfjlka: NOA\n"
"asdf:NOA(lkjasdlfkjasf)\n\n\n"
"Version: RE2 for Google Sheets\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.