const regex = new RegExp('^(?:[^N\\n]|N(?:[^O\\n]|O(?:[^A\\n]|$)|$)|$)+', 'gm')
const str = `I want to delete anything in a line but stop before the word NOA if that is present in a line. NOA will also follow a colon.
1: NOA Keep this)
2 lkajsflk: DONT KEEP THIS
asdlkjfaskldjf: Dont keep this
asdfjlka: NOA
asdf:NOA(lkjasdlfkjasf)
Version: RE2 for Google Sheets
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);