using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[word1|bord2]";
string input = @"] word1
word2 [
] word1 [
] word2 [
word2
word2
] word1
word1 [";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}