package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[word1|bord2]`)
var str = `] word1
word2 [
] word1 [
] word2 [
word2
word2
] word1
word1 [`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}