$re = '/[word1|bord2]/';
$str = '] word1
word2 [
] word1 [
] word2 [
word2
word2
] word1
word1 [';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);