re = /[word1|bord2]/
str = '] word1
word2 [
] word1 [
] word2 [
word2
word2
] word1
word1 ['
# Print the match result
str.scan(re) do |match|
puts match.to_s
end