using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(?:\d+\.)?\s*\K\S+(?: +\S+){1,2}";
string input = @"This will work without problem
This heading too
This item list will work too
1. This wont work
2. Not working
3. Neither this one
But this works again";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}