re = /^\s*(?:\d+\.)?\s*\K\S+(?: +\S+){1,2}/m
str = 'This will work without problem
This heading too
This item list will work too
1. This wont work
2. Not working
3. Neither this one
But this works again'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end