$re = '/^\s*(?:\d+\.)?\s*\K\S+(?: +\S+){1,2}/m';
$str = 'This will work without problem
This heading too
This item list will work too
1. This wont work
2. Not working
3. Neither this one
But this works again';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);