import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?:\\d+\\.)?\\s*\\K\\S+(?: +\\S+){1,2}";
final String string = "This will work without problem\n"
+ "This heading too\n"
+ "This item list will work too\n"
+ "1. This wont work\n"
+ "2. Not working\n"
+ "3. Neither this one\n"
+ "But this works again";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}