using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w]+:)(""(([^""])*)""|'(([^'])*)'|(([^\s])*))";
string input = @"category:""live casino"" gsp:S1aik-UBnl a:""b"" c:'d e' f:g h:c x:";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}