re = /([\w]+:)("(([^"])*)"|'(([^'])*)'|(([^\s])*))/
str = 'category:"live casino" gsp:S1aik-UBnl a:"b" c:\'d e\' f:g h:c x:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end