import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w]+:)(\"(([^\"])*)\"|'(([^'])*)'|(([^\\s])*))";
final String string = "category:\"live casino\" gsp:S1aik-UBnl a:\"b\" c:'d e' f:g h:c x:";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}