package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w]+:)("(([^"])*)"|'(([^'])*)'|(([^\s])*))`)
var str = `category:"live casino" gsp:S1aik-UBnl a:"b" c:'d e' f:g h:c x:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}